Changelog

All the latest updates, improvements and bug fixes for all KISO products
  1. Fixed issue with `sass-rails`, and parallax.js

    fixed
    2019-10-10
    1.0.1
    - kiso-themes
    There was an issue with Rails 6 and `sass-rails` pinned to versions greater than 6.0.0.beta3. This has been resolved now that sass-rails 5.1.0 now works with Rails 6, so the dependency constraint has been relaxed. Also fixes an issue with `jquery-parallax.js` having the wrong npm package installed. If you're having an issue in an existing generated project, simply run: ``` yarn remove parallax.js yarn add jquery-parallax.js In application.js, change line 24 from require('parallax.js') to require('jquery-parallax.js') ```
  2. Subscription Controller params & LifecycleHooks moved

    fixed
    2019-09-17
    1.0.1
    - kiso_stripe_payments
    The Stripe Subscription Controller had some missing whitelisted params in the strong parameter handling, which is now fixed. Also, in Rails 6, the `lifecycle_hooks.rb` file may not have been properly detected with the new Zeitwerk loader. It has been moved to `app/event_handlers/kiso_stripe_payments/lifecycle_hooks.rb` - if you have already generated your project and receive errors about `LifecycleHooks` not being defined, simply move the file to the same location above.
  3. Initial Version

    added
    2019-08-19
    1.0.0
    - kiso_themes
    The initial version of kiso_themes.
  4. Initial Version

    added
    2019-08-19
    1.0.0
    - kiso_stripe_payments
    The initial version of kiso_stripe_payments.
  5. Initial Version

    added
    2019-08-19
    1.0.0
    - kiso_crate
    The initial version of kiso_crate.

Accelerate your Rails app development today

Join our mailing list

Be the first to hear about product announcements, new blog posts and more via our low volume mailing list. Unsubscribe at any time. No Spam.
Copyright © 2012-2019 Kantan Designs Inc. All Rights Reserved.